I cannot install Joomla 3 due to the PHP version my hosting account is using?

Joomla was unable to be install because of the following error: A newer PHP version is required. Min: 5.3.1 Installed: 5.2.17

Hi I have tried to install Joomla 3.2 but keep getting the above message can you help?

Posted in Joomla!, asked by webx, 4 years ago. 11872 hits.

0

This means that the server you are currently on is using PHP version 5.2.17 which is perfect for Joomla 1.5 but sadly, Joomla 1.5 cannot work with later versions of PHP which is where the problem lies! Joomla! 3.x is quite different and its recommended configuration is 5.4 + due to it being a later stream of Joomla.

This shouldn't be a big problem and we are happy to move you up but there may be different ways of doing this depending upon your preference:

1.) You can sign up for a new hosting account which will put you on the latest PHP versions and in line for hosting Joomla 3.x. When you are happy with your new installation you can cancel your old hosting account and request that your domain name be pointed to your new account. Many users like to do this as it means that you can keep your old Joomla 1.5 website running while you get the new Joomla 3.x system up and tested,

2.) Or alternatively we will be happy to move your account up to a later server using PHP 5.4 +. This will bring you in line with Joomla recommended configuration for Joomla 3.x. Please note that Joomla! 1.5 cannot work on PHP 5.4+ so any 1.5 installations will probably break when the account is upgraded.

If you would like to go ahead with any of these options please feel welcome to raise a ticket and we will be happy to assist you.

webx
4 years ago
Please register/login to answer this question.  Click here to login
- Just now

0

Just now
/faqs
/faqs/get_answer/30
/faqs/save_reply/30
/faqs/save_answer/30
/faqs/accept_answer/30
/faqs/unaccept_answer/30
/faqs/unpublish_answer/30
/faqs/delete_answer/30
/faqs/update_answer/30
/faqs/like/30
/faqs/dislike/30
/faqs/report_answer/30
/faqs/report_question/30